Deployment Issue Impacting Data Ingestion

Incident Report for Minimum

Resolved

The issue has been fully resolved. All systems are operating normally. We apologize for any inconvenience this may have caused, and we appreciate your patience.
Posted Jun 05, 2025 - 10:19 UTC

Update

We're in the process of rolling back. We're monitoring progress closely and will provide further updates as recovery continues.
Posted Jun 05, 2025 - 10:06 UTC

Identified

We’re currently experiencing an issue related to a recent deployment that is impacting key parts of the Platform. Data submission, the Hub, and all Data Ingestion-related functionalities are currently unavailable. This affects any customers attempting to submit data.

Our team is actively working to resolve the issue.
Posted Jun 05, 2025 - 09:29 UTC
This incident affected: UK (Dashboard, API) and Middle East - UAE (Dashboard, API).