Explo dashboards not loading

Incident Report for Minimum

Resolved

The issue affecting Explo dashboards has been resolved.

We’ll continue monitoring the system closely. Thank you for your patience, and we apologize for any disruption caused.
Posted Nov 18, 2025 - 19:03 UTC

Monitoring

The issue affecting loading of Explo dashboards has been resolved, although Cloudflare is still not reporting end of the incident.

We’ll continue monitoring the system closely. Thank you for your patience, and we apologize for any disruption caused.
Posted Nov 18, 2025 - 15:26 UTC

Investigating

Explo reported that they have accessibility issues due to Cloudflare infrastructure outage. We’ll share updates as we get them.
Posted Nov 18, 2025 - 15:00 UTC

Identified

We are currently investigating an issue affecting Explo dashboards.

Our team is actively working on it. We’ll share updates here until resolved.
Posted Nov 18, 2025 - 14:40 UTC